New Lotus Notes Attachment Viewer 2.0.1 posted

The Attachment Viewer 2.0.1 for Lotus Notes is now posted on this site. I fixed a couple of problems reported and it looks like the Microsoft Office Converter EXE is now behaving a bit better. From the original post (click here), you may need to install the inter-op libraries for your version of MS Office in order to use it. You need to be running at least Lotus Notes 8.5.2 for this update.

Drag this to My Widgets in Lotus Notes


The option to not install the MS Office Viewer via Widgets has been retracted because Widgets do not allow this. So you will have to install it the MS Office Viewer but it may not work for those file formats.

Quick Tests I ran:

I have tested this on Windows XP, Windows Vista and Windows 7 (64bit) and it appears to be working fine. I have also tested it on Lotus Notes 8.5.2 and the new 8.5.3. Lastly, I have also tested with Microsoft Office 2003, 2007 and 2010.

Some known issues:

  • I have had some crashes on restart of the Notes client but just relaunching Notes seems to be fine after that.
  • Some ODP files do not work, if the file selection does work click on it again and it may work.
  • This is a Dojo based version where I pull the Dojo code from the Google CDN. So currently you must be online in order to use this widget.

29 thoughts on “New Lotus Notes Attachment Viewer 2.0.1 posted

  1. It looks like the MS Office viewer is working for some and not others. If you could send me any problems, screen shots or logs if you are having problems to bob [at] balfes.net I would appreciate it.

    Like

  2. Hi Bob,

    Will this work under 8.5.2 in Ubuntu10.10. When I dragged the .xml file to my widget sidebar panel I got an import error message.

    Nick

    Like

  3. Hi Bob,

    I had issues installing the widget in 8.5.3 CD4 on the Mac.
    Commenting out the feature “org.openntf.attachmentviewer.ms_office.feature” in the extension.xml file helped, but isn’t there a better way to produce the widget so that it works cross-platform?
    I saw version=”2.0.1.beta” in the XML code. I’m wondering if “beta” is a supported qualifier.

    Anyway, looks like the attachment viewer is working now. Thanks for that, the plugin is really useful!

    Here are the log entries for the issue:

    WARNING
    com.ibm.rcp.provisioning.internal.impl.ProvisioningServiceImpl
    process
    CWPPR0032E: The requested provisioning operation(s) failed.
    CWPPR0030W: Feature org.openntf.attachmentviewer.ms_office.feature_2.0.1.beta is not installed on the platform.
    com.ibm.rcp.provisioning
    08:40:21.414
    13
    WARNING
    com.ibm.rcp.provisioning.internal.impl.ProvisioningServiceImpl
    process
    CWPPR0032E: The requested provisioning operation(s) failed.
    CWPPR0030W: Feature org.openntf.attachmentviewer.ms_office.feature_2.0.1.beta is not installed on the platform.
    com.ibm.rcp.provisioning
    08:40:21.418
    14
    SEVERE
    com.ibm.rcp.toolbox.prov.provider.ProvController
    provision
    CWPPR0032E: The requested provisioning operation(s) failed.
    com.ibm.rcp.toolbox.prov.provider
    08:40:21.419
    14
    SEVERE
    com.ibm.rcp.toolbox.prov.provider.ProvController
    provision
    CWPPR0032E: The requested provisioning operation(s) failed.
    com.ibm.rcp.toolbox.prov.provider
    08:40:21.420
    14
    SEVERE
    com.ibm.rcp.toolbox.internal.stores.PalleteStore
    loadCollection
    CLFWW0030E: Could not add widget Attachment Viewer

    Karsten

    Like

  4. @Nick – what kind of error did you receive? It should work but the Office support wont since its a Win32 EXE.

    @Karsten – it should work fine, that feature should not install since its targeted for Mac. I believe you can use anything in the qualifier so that should not be a problem.

    Like

  5. Looks like Widgets do not allow the installation of a widget and saying No to one of the plugins. I will have to create a feature fragment to get this to install on anything outside of Windows.

    Thanks for the quick responses guys!

    Like

  6. Bob,

    I forget the exact error message (sorry not helpful). I have tried just now I drag the xml file to my widgets and thats the last I see of your web page. It totally crash’s the page. So I have to close the page and go back in again.

    On the Notes side absolutely nothing happens, just like I had done nothing.

    On another point why are we worried about MS office anything when running on a Linux system???

    Nick

    Like

  7. I´m unable to install it now. I’ve found link to update site that doesn’t work anymore. Is it just me, or is there something wrong 😦

    Like

  8. Thanks. Will you publish this version on OpenNTF some day? 🙂 We’ve currently hit the limitation that it uses Dojo from external sources. Users wanted to test in locked-down test environment with no connection to internet, so I would like to modify it to point to some internal location.

    Thanks,

    Martin

    Like

  9. Bob, sometimes when I try to install the Attachment Viewer, any version, I receive an error message “Widgets Import Error” and the install quits. I’m directed to a log for details; i.e., NRPC://server/_8625715D00706BA9/blah, blah/$file/extension.xml, but
    I haven’t been able to find a log referencing this either on the server or on the local pc.

    What I’m wondering is how can I get the Attachment Viewer installed on these pc’s?

    Thanks.

    Like

    • Are you using the database to role it out? It looks like the server in the URL is not correct. Make sure if you use a composite application you get that URL correct. Otherwise deploy it as a widget, which is the best practice.

      Like

      • Actually, I drug it directly from the link above to My Widgets in the Notes Client. In my post above, I replaced my server name with “server” and the “blah, blah” was just my way of shortening the long string of numbers listed in the error message.

        But the puzzling thing is, the Attachment Viewer had not been installed on this user’s client before, so it shouldn’t have had issues. However, this same thing has happened at least five times this year on different users. None have had the widget installed before.

        Like

  10. We are slowly upgrading to Windows 7 and Notes 9 and have noticed that the Attachment Viewer is having trouble installing. Do you know of any issues with the Attachment Viewer and Windows 7 and/or Notes 9?

    BTW…we love the Attachment Viewer!

    Like

  11. No issues come up in the log. It just takes a while installing, then loading. 10+ minutes. But one my machine, it eventually came up.

    I’ll watch it and if anything comes up in the log, I’ll post it.

    Thanks for getting back to me.

    Like

  12. Hi,

    I have Windows 7 32bit and Lotus Notes 9 – everything works perfectly (version 1 and 2). When I have Windows 7 64bit and Lotus Notes 9 – Attachments aren´t displayed. Windows 7 64bit and Lotus Notes 8.5 – OK.
    Do you have any idea?

    Thank you

    Like

  13. Here is the error we get in the log when AttachmentViewer has been installed. It doesn’t have any problems installing, it just get’s hung Loading. I thought it would eventually finish, but this went on for days. I found this in the Log Viewer. Any ideas would be appreciated:

    Could not install bundle ../../shared/eclipse/plugins/com.ibm.json4j_9.0.0.20130228-1411.jar Bundle “com.ibm.json4j” version “9.0.0.20130228-1411” has already been installed from: update@plugins/com.ibm.json4j_9.0.0.20130228-1411.jar

    Like

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s